Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-63888

New global setting for messaging "messagingallusers" is not returned by WS for the app

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 3.5.2
    • 3.6
    • Web Services
    • MOODLE_35_STABLE
    • MOODLE_36_STABLE
    • MDL-63888-master
    • Hide
      1. As admin, enable "Mobile services": Site administration ► Mobile app ► Mobile settings
      2. Create a Token in the mobile app service for any user in the site (not an admin account)
        • Click on Site administration ► Plugins ► Web services ► Manage tokens
      3. Open the console an execute this new curl request, replacing wstoken with the token you just created and the site url with yours.

        curl 'http://localhost/m/stable_master/webservice/rest/server.php?moodlewsrestformat=json' --data 'wsfunction=core_webservice_get_site_info&wstoken=3af67232a7596ceb658df4db329e5ad6' | python -m "json.tool"

      4. And check that the returned advancedfeatures -> messagingallusers field value is set to the same value that the global setting that can be found at "Site administration -> Advanced features" (If the setting is checked, the value returned will be 1, if is not checked the value returned will be 0)
      Show
      As admin, enable "Mobile services": Site administration ► Mobile app ► Mobile settings Create a Token in the mobile app service for any user in the site (not an admin account) Click on Site administration ► Plugins ► Web services ► Manage tokens Open the console an execute this new curl request, replacing wstoken with the token you just created and the site url with yours. curl 'http://localhost/m/stable_master/webservice/rest/server.php?moodlewsrestformat=json' --data 'wsfunction=core_webservice_get_site_info&wstoken=3af67232a7596ceb658df4db329e5ad6' | python -m "json.tool" And check that the returned advancedfeatures -> messagingallusers field value is set to the same value that the global setting that can be found at "Site administration -> Advanced features" (If the setting is checked, the value returned will be 1, if is not checked the value returned will be 0)

    Description

      MDL-63214 introduced a new setting but is not being returned to the app via the get_siteinfo WS

      Attachments

        Issue Links

          Activity

            People

              jleyva Juan Leyva
              jleyva Juan Leyva
              Albert Gasset Albert Gasset
              David Monllaó David Monllaó
              Janelle Barcega Janelle Barcega
              Juan Leyva, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Laurent David, Raquel Ortega, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                3/Dec/18

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 10 minutes
                  10m