Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-63966

Phase 2 of deprecation of functions in lib/deprecatedlib.php initially deprecated in 3.6

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.6
    • Fix Version/s: None
    • Component/s: General
    • Labels:
      None

      Description

      As per https://docs.moodle.org/dev/Deprecation all functions in lib/deprecatedlib.php that were deprecated in 3.6 should be replaced with exceptions in 4.0

      This includes all functions in lib/deprecatedlib.php that say @deprecated since 3.6

      If any functions from this file do not have this comment but also need to be finally deprecated in 4.0 - please list them in this issue description

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: