Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-64021

Autolink on activities is not working when activity name ends with punctuation mark

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.5.2
    • Fix Version/s: None
    • Component/s: Filters
    • Labels:
      None
    • Affected Branches:
      MOODLE_35_STABLE

      Description

      Since the update on Moodle 3.5.2 from 3.5 a lot of autolinks in activities on other activities are gone. After a while it was clear that only the autolinks on activities that had question a mark or exclamation marks at the end where broken.

      Steps to reproduce:

      In a course set the filter 'autolink on activities' -> on

      Create a task where the title ends with a punctuation mark

      Example: Which material is suitable?

      Create a second task with a title: Build an alarm system

      In the description to that task copy the title of the first task ;  save and look at the description

      It should be a link to the first task but is only plain text.

      Delete the punctuation mark in the title of the first task

      Look at the description of the second task -> the Text is now a autolink and the punctuation mark at the end is plain text

       

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              lucaboesch Luca Bösch
              Reporter:
              kkrueger Katja Krüger
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: