Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-64500

Missing 'no invalid analysables' message in 'invalid analysable elements' report

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.5.3, 3.6, 3.7
    • Fix Version/s: 3.5.5, 3.6.3
    • Component/s: Analytics
    • Labels:
    • Testing Instructions:
      Hide
      1. Create a brand new site
      2. Go to site admin > analytics > analytics models
      3. In "students at risk of dropping out" row, select "Invalid site elements" from the 'Actions' menu
      4. There SHOULD NOT be a table with headers like "Name" or "Invalid to train the model"
      5. There SHOULD be a info notification stating that there are no invalid elements to list
      6. Open a new browser tab and create two courses with no end date
      7. Refresh the "Invalid site elements" report
      8. There SHOULD see a table and two courses underneath it
      9. There SHOULD NOT be a info notification stating that there are no invalid elements to list
      Show
      Create a brand new site Go to site admin > analytics > analytics models In "students at risk of dropping out" row, select "Invalid site elements" from the 'Actions' menu There SHOULD NOT be a table with headers like "Name" or "Invalid to train the model" There SHOULD be a info notification stating that there are no invalid elements to list Open a new browser tab and create two courses with no end date Refresh the "Invalid site elements" report There SHOULD see a table and two courses underneath it There SHOULD NOT be a info notification stating that there are no invalid elements to list
    • Affected Branches:
      MOODLE_35_STABLE, MOODLE_36_STABLE, MOODLE_37_STABLE
    • Fixed Branches:
      MOODLE_35_STABLE, MOODLE_36_STABLE
    • Pull from Repository:
    • Pull 3.5 Branch:
    • Pull 3.6 Branch:
    • Pull Master Branch:
      MDL-64500_master

      Description

      The invalid analysable elements report in tool_analytics lists analysable elements in the site that can not be analysed. When there are no analysable elements or all the analysable elements can be analysed we show an empty table with no message. This is a not very user friendly solution and users may even thing that something went wrong. We should ideally show a message saying that there are no invalid analysable elements.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                11/Mar/19

                Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 25 minutes
                25m