Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-64614

Decide Moodle 3.8 requirements and push them to environment.xml (due date: 2019-06-03)

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.7
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Testing Instructions:
      Hide

      A - On Master, 36, 35, 34 and 31 (all supported and security supported branches):

      1. Go to admin -> server -> environment
      2. One "3.8 upwards" Moodle version should be available.
      3. VERIFY that It shows the same requirements than a 3.7 version but with these differences:
        1. TO DECIDE

      B - Verify, for all the numeric (XY) branches above, that the environment.xml file is 100% the same (requires git or diff use). All the commands should return NO differences (nothing should be output):

      1. git diff MOODLE_XY_STABLE master admin/environment.xml

      C - Upgrade tests (easier with MDK):

      C-1 Using minimum supported version

      1. Install Moodle 3.2.0
        1. Uninstall your current instance

          mdk uninstall -y
          

        2. Checkout the 3.2.0 tag

          git checkout v3.2.0
          

        3. Install

          mdk install
          

      2. Add some courses and one activity or two

        mdk run makecourse
        

      3. Attempt upgrade to master
        1. Checkout the master branch.

          git checkout master
          

        2. Upgrade either via the browser or via CLI (mdk upgrade)
      4. VERIFY: that upgrade works

      C-2 Using older, non-supported version

      1. Install Moodle 3.1.x
        1. Uninstall your current instance

          mdk uninstall -y
          

        2. Checkout the 3.1.0 tag

          git checkout v3.1.0
          

        3. Install

          mdk install
          

      2. Add some courses and one activity or two

        mdk run makecourse
        

      3. Attempt upgrade to master
        1. Checkout the master branch.

          git checkout master
          

        2. Open the moodle instance on your browser
      4. VERIFY: that upgrade is blocked
      Show
      A - On Master, 36, 35, 34 and 31 (all supported and security supported branches): Go to admin -> server -> environment One "3.8 upwards" Moodle version should be available. VERIFY that It shows the same requirements than a 3.7 version but with these differences: TO DECIDE B - Verify, for all the numeric (XY) branches above, that the environment.xml file is 100% the same (requires git or diff use). All the commands should return NO differences (nothing should be output): git diff MOODLE_XY_STABLE master admin/environment.xml C - Upgrade tests (easier with MDK): C-1 Using minimum supported version Install Moodle 3.2.0 Uninstall your current instance mdk uninstall -y Checkout the 3.2.0 tag git checkout v3.2.0 Install mdk install Add some courses and one activity or two mdk run makecourse Attempt upgrade to master Checkout the master branch. git checkout master Upgrade either via the browser or via CLI ( mdk upgrade ) VERIFY : that upgrade works C-2 Using older, non-supported version Install Moodle 3.1.x Uninstall your current instance mdk uninstall -y Checkout the 3.1.0 tag git checkout v3.1.0 Install mdk install Add some courses and one activity or two mdk run makecourse Attempt upgrade to master Checkout the master branch. git checkout master Open the moodle instance on your browser VERIFY : that upgrade is blocked
    • Affected Branches:
      MOODLE_37_STABLE

      Description

      Policy: PHP & Moodle supported versions

      Since Moodle 3.5 (MDL-59159), these rules apply to decide Minimum PHP and Moodle versions supported:

      1. A LTS will always require the previous LTS (or later) for upgrading.
      2. The maximum PHP version supported for a branch will be the max one achieved along the life of the branch. Usually with .0 releases but may happen later (we added support for php70 with 3.0.1, for example).
      3. The minimum PHP version supported for a branch will be the lower of:
        • The minimum version supported in any way by php the day of the Moodle release (so we provide slow, progressive increments).
        • The maximum PHP version supported by the previous LTS branch (so we guarantee jumping between LTS is possible without upgrading PHP at the same time).

      We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

      All the still open linked issues have been also cloned here from the 3.7 sister issue (MDL-63276).

      Usual discussions:

      Feel free to propose areas to be discussed here. A numbered list with all them will be created to vote and decide the final outcomes of this issue.

      TIA and ciao

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated: