Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-64614

Decide Moodle 3.8 requirements and push them to environment.xml (due date: 2019-06-10)

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.7
    • Fix Version/s: 3.5.7, 3.6.5, 3.7.1
    • Component/s: Installation
    • Labels:
    • Testing Instructions:
      Hide

      0 - Prerequisites

      1. Because the only change decided is to raise SQL*Server requirements from current 2008 (10) to 2012 (11), all the sites used along the testing below should be using SQL*Server as database (ideally >= 2012).
        ^^^ Note: Surely the easiest way to achieve that is to use the moodlehq/moodle-db-mssql docker image.
      2. Ensure that there is NOT any $CFG->moodledata/environment directory in your installation. If it exists... it contains old environment info. Remove the directory completely before continue with the tests below.

      A - On Master, 37, 36 and 35 (all supported and security supported branches):

      1. Go to admin -> server -> environment
      2. One "3.8 upwards" Moodle version should be available.
      3. VERIFY that It shows the same requirements than a 3.7 version but with these differences:
        1. The "database" check shows "version 11.0 is required and you are running xxxxx" (instead of the "version 10.0 is required..." shown for 3.7). Verify that the "xxxxx" above is >= 11.0.

      B - Verify, for all the numeric (XY) branches above, that the environment.xml file is 100% the same (requires git or diff use). All the commands should return NO differences (nothing should be output):

      1. git diff MOODLE_XY_STABLE master admin/environment.xml

      C - Upgrade tests (easier with MDK):

      C-1 Using minimum supported version

      1. Install Moodle 3.2.0
        1. Uninstall your current instance

          mdk uninstall -y
          

        2. Checkout the 3.2.0 tag

          git checkout v3.2.0
          

        3. Install

          mdk install
          

      2. Add some courses and one activity or two

        mdk run makecourse
        

      3. Attempt upgrade to master
        1. Checkout the master branch.

          git checkout master
          

        2. Upgrade either via the browser or via CLI (mdk upgrade)
      4. VERIFY: that upgrade works

      C-2 Using older, non-supported version

      1. Install Moodle 3.1.x
        1. Uninstall your current instance

          mdk uninstall -y
          

        2. Checkout the 3.1.0 tag

          git checkout v3.1.0
          

        3. Install

          mdk install
          

      2. Add some courses and one activity or two

        mdk run makecourse
        

      3. Attempt upgrade to master
        1. Checkout the master branch.

          git checkout master
          

        2. Open the moodle instance on your browser
      4. VERIFY: that upgrade is blocked
      Show
      0 - Prerequisites Because the only change decided is to raise SQL*Server requirements from current 2008 (10) to 2012 (11), all the sites used along the testing below should be using SQL*Server as database (ideally >= 2012). ^^^ Note: Surely the easiest way to achieve that is to use the moodlehq/moodle-db-mssql docker image. Ensure that there is NOT any $CFG->moodledata/environment directory in your installation. If it exists... it contains old environment info. Remove the directory completely before continue with the tests below. A - On Master, 37, 36 and 35 (all supported and security supported branches): Go to admin -> server -> environment One "3.8 upwards" Moodle version should be available. VERIFY that It shows the same requirements than a 3.7 version but with these differences: The "database" check shows "version 11.0 is required and you are running xxxxx"  (instead of the "version 10.0 is required..." shown for 3.7). Verify that the "xxxxx" above is >= 11.0. B - Verify, for all the numeric (XY) branches above, that the environment.xml file is 100% the same (requires git or diff use). All the commands should return NO differences (nothing should be output): git diff MOODLE_XY_STABLE master admin/environment.xml C - Upgrade tests (easier with MDK): C-1 Using minimum supported version Install Moodle 3.2.0 Uninstall your current instance mdk uninstall -y Checkout the 3.2.0 tag git checkout v3.2.0 Install mdk install Add some courses and one activity or two mdk run makecourse Attempt upgrade to master Checkout the master branch. git checkout master Upgrade either via the browser or via CLI ( mdk upgrade ) VERIFY : that upgrade works C-2 Using older, non-supported version Install Moodle 3.1.x Uninstall your current instance mdk uninstall -y Checkout the 3.1.0 tag git checkout v3.1.0 Install mdk install Add some courses and one activity or two mdk run makecourse Attempt upgrade to master Checkout the master branch. git checkout master Open the moodle instance on your browser VERIFY : that upgrade is blocked
    • Affected Branches:
      MOODLE_37_STABLE
    • Fixed Branches:
      MOODLE_35_STABLE, MOODLE_36_STABLE, MOODLE_37_STABLE
    • Pull from Repository:
    • Pull 3.5 Branch:
    • Pull 3.6 Branch:
    • Pull 3.7 Branch:
    • Pull Master Branch:

      Description

      Policy: PHP & Moodle supported versions

      Since Moodle 3.5 (MDL-59159), these rules apply to decide Minimum PHP and Moodle versions supported:

      1. A LTS will always require the previous LTS (or later) for upgrading.
      2. The maximum PHP version supported for a branch will be the max one achieved along the life of the branch. Usually with .0 releases but may happen later (we added support for php70 with 3.0.1, for example).
      3. The minimum PHP version supported for a branch will be the lower of:
        • The minimum version supported in any way by php the day of the Moodle release (so we provide slow, progressive increments).
        • The maximum PHP version supported by the previous LTS branch (so we guarantee jumping between LTS is possible without upgrading PHP at the same time).

      We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

      All the still open linked issues have been also cloned here from the 3.7 sister issue (MDL-63276).

      Usual discussions:

      Feel free to propose areas to be discussed here. A numbered list with all them will be created to vote and decide the final outcomes of this issue.

      TODO: Once applied upstream, changes are needed @ download.moodle.org to show the new requirements there.

      TIA and ciao

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                2 Vote for this issue
                Watchers:
                18 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  8/Jul/19

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 day, 45 minutes
                  1d 45m