Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-6478

Unit tests (not) working - Simpletest

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7
    • Component/s: Other
    • Labels:
      None
    • Environment:
      All.
    • Database:
      Any
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE

      Description

      From OU Bugzilla Bug 1351. At present, with limited use of unit tests no problems have been found, but it's best to copy fixes and enhancements (from OU local cvs) to lib/simpletestlib.php functions now:

      load_test_table - parameters.
      load_test_data
      wipe_sequences - global.
      _private_execute_sql

      Note, simpletestlib.php now contains functions/classes from OU _tools/runsimpletest/dbutils.php, expectations.php ... and others.

        Attachments

          Activity

            People

            Assignee:
            nfreear Nick Freear
            Reporter:
            nfreear Nick Freear
            Tester:
            Nobody
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Sujith Haridasan
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              7/Nov/06