Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-64790

Wrong parameter name in API documentation of function upgrade_plugin_savepoint in upgradelib.php

    XMLWordPrintable

    Details

      Description

      Commit 17da2e6f28d3477eb4ccfe5ac94c9cebb8456c8e (fix for MDL-16438) contains changes to function upgrade_plugin_savepoint in lib/upgradelib.php. These changes rename parameter $dir of the function to $plugin. The API documentation (PHPDoc comment block above the function) has not been changed accordingly. Result: it still lists the old parameter $dir, which is wrong.

      How to fix

      Rename ‘$dir’ to ‘$plugin’ in PHPDoc comment for function upgrade_plugin_savepoint in lib/upgradelib.php.

      Note: should also update the @param comment text so that it is more meaningful to developers (it should perhaps not refer to the location of the plugin, but to its name or so).

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  13/May/19

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 30 minutes
                  30m