Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-64900

Error when importing competency framework and competencies are disabled

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.6
    • Fix Version/s: None
    • Component/s: Competencies
    • Labels:
    • Affected Branches:
      MOODLE_36_STABLE

      Description

      When competencies are disabled (through the  setting), the following error appears when trying to import a competency framework:

       

      Competencies are not enabled.
      More information about this error
      ×Debug info: 
      Error code: competenciesarenotenabled
      ×Stack trace:
      line 70 of /competency/classes/api.php: moodle_exception thrown
      line 548 of /competency/classes/api.php: call to core_competency\api::require_enabled()
      line 464 of /admin/tool/lpimportcsv/classes/framework_importer.php: call to core_competency\api::create_framework()
      line 64 of /admin/tool/lpimportcsv/index.php: call to tool_lpimportcsv\framework_importer->import()
      

       

       

      I would suggest hiding the Import competency framework or let to import competencies (even if they are disabled).

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sarjona Sara Arjona (@sarjona)
                Participants:
                Component watchers:
                Damyon Wiese, Jean-Philippe Gaudreau, Steve Massicotte, Serge Gauthier, Issam Taboubi, Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: