Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-3413

Upgrade from 1.5.4+ to 1.6.1+ stops with hotpot error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.9.11
    • Fix Version/s: None
    • Component/s: Module: HotPot
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      I've just installed a clean 1.5.4+ copy (2005060241) to test the patch provided in MDL-6147. This 1.5.4+ installation works as expected. But when I try to upgrade that copy to 1.6.1+ (2006050513), it stops at the HotPot module upgrade, with a message telling:

      Version mismatch: hotpot can't downgrade 2006082800 -> 2006080701 !

      It seems Gordon Bateson updated the HotPot module un 1.5.4+ recently (on 2006.08.29, according to CVS) and now the version number in 1.5.4+ is greater than the version number in 1.6.1+, which completely stops the upgrade process.

      I guess making the 1.6.1+ HotPot module version number higher would be enough.

      Saludos. Iñaki.

        Attachments

          Activity

            People

            Assignee:
            dougiamas Martin Dougiamas
            Reporter:
            iarenaza Iñaki Arenaza
            Tester:
            Nobody
            Participants:
            Component watchers:
            Gordon Bateson
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: