Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-65214

Update upgrade_stale_php_files_present() before 3.7 release

    XMLWordPrintable

Details

    • Task
    • Resolution: Fixed
    • Minor
    • 3.7
    • 3.7
    • Installation
    • MOODLE_37_STABLE
    • MOODLE_37_STABLE
    • Hide

      web

      1. Create and install a 3.6.x site. For example:

        git checkout v3.6.0
        

      2. Check out the master branch

        git checkout master
        

      3. Create any of the following files that are being detected by the patch. (e.g. on Linux, use the "touch" command):
        • lib/form/yui/src/showadvanced/js/showadvanced.js

          mkdir -p lib/form/yui/src/showadvanced/js
          touch lib/form/yui/src/showadvanced/js/showadvanced.js
          

        • lib/tests/output_external_test.php

          touch lib/tests/output_external_test.php
          

        • message/amd/src/message_area.js

          touch message/amd/src/message_area.js
          

        • message/templates/message_area.mustache

          touch message/templates/message_area.mustache
          

        • question/yui/src/qbankmanager/build.json

          mkdir question/yui/src/qbankmanager
          touch question/yui/src/qbankmanager/build.json
          

      4. Open your Moodle instance on your browser.
      5. Log in as admin and proceed with the upgrade.
      6. Verify that a notice ("Mixed Moodle versions detected....") is displayed saying that there are problems upgrading and a proper procedure for upgrading to a major release.
      7. Delete the touched file(s) in 2.
      8. Click "Reload".
      9. Verify that the upgrade now proceeds ok.

      cli

      1. Disclaimer: CLI upgrade does not run the upgrade_stale_php_files_present() check. MDL-53596 has been created about that. Nothing to test here yet.
      Show
      web Create and install a 3.6.x site. For example: git checkout v3.6.0 Check out the master branch git checkout master Create any of the following files that are being detected by the patch. (e.g. on Linux, use the " touch " command): lib/form/yui/src/showadvanced/js/showadvanced.js mkdir -p lib/form/yui/src/showadvanced/js touch lib/form/yui/src/showadvanced/js/showadvanced.js lib/tests/output_external_test.php touch lib/tests/output_external_test.php message/amd/src/message_area.js touch message/amd/src/message_area.js message/templates/message_area.mustache touch message/templates/message_area.mustache question/yui/src/qbankmanager/build.json mkdir question/yui/src/qbankmanager touch question/yui/src/qbankmanager/build.json Open your Moodle instance on your browser. Log in as admin and proceed with the upgrade. Verify that a notice ("Mixed Moodle versions detected....") is displayed saying that there are problems upgrading and a proper procedure for upgrading to a major release. Delete the touched file(s) in 2. Click " Reload ". Verify that the upgrade now proceeds ok. cli Disclaimer: CLI upgrade does not run the upgrade_stale_php_files_present() check. MDL-53596 has been created about that. Nothing to test here yet.

    Description

      Simply verify we have a number (4-5) of files for the next major release. They all must be files deleted since last stable version and current master

      git diff --name-status MOODLE_XX_STABLE..master | grep ^D
      

      Note that it's better not to pick any plugin file that maybe reinstalled manually (exception being forum files because that plugin is mandatory).

      Attachments

        Issue Links

          Activity

            People

              stronk7 Eloy Lafuente (stronk7)
              stronk7 Eloy Lafuente (stronk7)
              David Mudrák (@mudrd8mz) David Mudrák (@mudrd8mz)
              Jun Pataleta Jun Pataleta
              Jennifer Bauzon Jennifer Bauzon
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 3 hours, 20 minutes
                  3h 20m

                  Clockify

                    Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.