Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: None
    • Component/s: Workshop
    • Labels:
      None
    • Environment:
      All
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_11_STABLE
    • Rank:
      7317

      Description

      The workshop module seems great, once you start to understand it, and it is full of possibilities, but there are still some problems to fix:

      I am working with the latest Moodle Beta 1.1 (2003082200). I have just downloaded and installed it from the latest hourly .zip.

      1) There is a famous warning in workshop module being Warning: Invalid argument supplied for foreach() in /home/aprendi/public_html/moodle/lib/weblib.php on line 1054

      It appears in many places:

      1.1) After setting up a workshop (with 1 student assesment and 1 example teacher assesment), when you go to Phase 1, admin, student assesments. In fact it will stay there untill any of your students makes an assesment. Even if you set your student assesments to 0 if fails the same way.

      1.2) Also in Phase 1, when you Submit example assignement. This submission is never seen by the students, they cannot work with it.

      1.3) The students will see also the warning in their views unless you set the example assesments to 0 in your workshop settings

      1.4) Whenever you clic on admin in teacher view.

      2) There are some terms wich are not translated. Is it an application or a translator's problem? For example, the scales such as very poor, excelent, yes, no... Weight,...

        Activity

        Martin Dougiamas added a comment -

        From Ray Kingdon (rkingdon at glam.ac.uk) Saturday, 23 August 2003, 10:05 PM:

        Thanks for this - I see the problem. I'm testing with workshops with submissions so I hadn't seen it. I've reproduced the bug now and with get back when it cleared, hopefully soon!

        From Ray Kingdon (rkingdon at glam.ac.uk) Sunday, 24 August 2003, 12:03 AM:

        Thanksagain for this, they were caused by things being missing. It should be fixed in CVS. The error 1.3 is interesting. It was caused by the teacher not submitting the examples in a workshop which requires examples. I've fixed that by stopping the workshop going to phase 2 if the number of examples is less than than the (minimum) number required.

        The fixes should be in the NIGHTLY in about 24 hours time. (I dont think it's an hourly .zip is it?)

        Oh the missing strings will be be there, that the translator's job. They are in the English version.

        Thanks

        Ray

        From Eloy Lafuente (stronk7 at moodle.org) Sunday, 24 August 2003, 02:17 AM:

        It's fixed so it is closed too !!

        From David Delgado (davidds at apren-d.com) Sunday, 24 August 2003, 04:34 AM:

        Many warnings have dissapeared with the latest version, but I am afrait it is not fixed yet. There is still a problem with the Assessments of Examples from Teacher, anyway we are now much closer to the whole fix.

        1) Create a new Workshop module with defaults but Number of Comments or Assessment Elements=2 (whatever you want), Number of Assessments of Examples from Teacher=1 and Number of Assessments of Student Submissions=1

        2) Enter the workshop as teacher. Submit Example Assignment. Upload any file. If you go back and return to Submit Example Assignment, you will get this: Notice: Undefined index: log in c:\archivos de programa\apache group\apache\htdocs\moodle\files\mimetypes.php on line 77.

        3) If you now enter as a student (for instance, in another browser), then you will find that the workshop is Not Available, just as it happened before, but now it cannot be solved by the teacher moving into Phase 2, since he cannot do that because a strange message appears telling that [[notenoughexamplessubmitted]]. ???

        4) If you change Number of Assessments of Examples from Teacher=0 at workshop settings everything works fine. So that is the problem: Assesments of Examples form Teacher is not working, and students never get the examples nor can assess them.

        From Ray Kingdon (rkingdon at glam.ac.uk) Sunday, 24 August 2003, 07:59 PM:

        Ah, I thought something like fixed/not closed meant it fixed I think/hope, I'll be less optimist in future

        davidds: I can't reduce your error in (2). Looks awesome! Has the teacher example file actually be saved? The files go in dataroot/courseid/moddate/workshop/submissionid/<file>

        That is if you go to the workshop directory you should see a directory for each submission (both teacher's and student's) and in each directory there's a single (uploaded) file. (The structure allows for multifile submissions planned for some time in the future.)

        In (3) the funny message is a new string warning the teacher they haven't submitted enough examples for this assignment yet.

        Can you do a quick dive into dataroot....

        Thanks

        Ray

        From David Delgado (davidds at apren-d.com) Monday, 25 August 2003, 08:24 AM:

        1) Has the teacher example file actually be saved? The files go in dataroot/courseid/moddate/workshop/submissionid/

        Yes it is saved. In fact, if you click on the file name, you can download it. If you look at its URL it is: http://localhost/moodle/file.php/3/moddata/workshop/13/WS_FTP.LOG

        And, of course, it is located at ~/moodledata/3/moddata/workshop/13/WS_FTP.LOG

        I still get the same Notice each time I access in Phase 1 to Submit Example Assignment and my students still see the Not Available message when trying to access workshop module, and never can see the example assignement. Any ideas?

        2) I found a new error when you go to Adminstration in any Phase, and try to re-assess any of the student submissions, you get this error:

        Notice: Undefined variable: sid in c:\archivos de programa\apache group\apache\htdocs\moodle\mod\workshop\assessments.php on line 205

        A required parameter was missing

        3) By the way, I have been looking at the language strings for workshop at ~/lang/en/workshop.php and you have some missing strings in it (even in the english version). I mean:

        a) The scale terms themselves. You have strings for the titles of the scales, but not for the scale terms themselves, such as Excelent or Very poor or even Yes or No. You are just hardcoding this terms with no allowed translation.

        b) The same happens wiht the term Weight: in singlular, used also in assesments.

        From Ray Kingdon (rkingdon at glam.ac.uk) Monday, 25 August 2003, 05:10 PM:

        davidds: Ecellent work!

        1) Yes I can now reproduce (that's what I meant to say in the last post) the miimetypes.php error. LOG is one of the types not built into Moodle and it doesn't know what icon to display against that type of file. That may be a bug but it's not a serious one, all the obvious files that a teacher/student might upload are recognised. (It's not a bug in the Workshop module.)

        The students should see not available when the workshop is in phase 1. Moving to phase 2 shou;ld open up the assignment to students.

        2) That's a workshop module bug!

        3) Whoops, yes - those strings (Yes, No...) are hard coded into the scales and they should NOT be. Another bug! I'll fix that hopefully in a couple of days time.

        Well done that's three bugs, two in Workshop and in mimetypes - that's great!

        Thanks

        Ray

        From David Delgado (davidds at apren-d.com) Wednesday, 27 August 2003, 11:42 PM:

        The hard coded strings are still there, and we only have today to fix it. Tomorrow Moodle 1.1 is released.

        Another bug is found in the messages that are sent by email to the workshop users, there are messages like this one, even in English:

        [[mail1]] [[mail2]]

        You can see it in your workshop assignment.

        And none of them are translated when you are working with workshops in other language not being English.

        From Ray Kingdon (rkingdon at glam.ac.uk) Thursday, 28 August 2003, 02:26 AM:

        david: Well spotted the [[mail1]]... slipped out - when clearing the more important 1054 bug I'm afraid.

        Those strings should now say sensible things in the email messages.

        I've also moved the hard-coded scale-end-point strings into the language module. They now need to percolate down through the translators...

        Keep up the bug-watch,

        Great work,

        Ray

        Michael Blake added a comment -

        assign to a valid user


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: