Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-65423

Incorrect possible value in the Mobile features multiple selector

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.6.3
    • Fix Version/s: 3.7
    • Component/s: Administration
    • Labels:
    • Testing Instructions:
      Hide
      1. Enable "Mobile services": Plugins ► Web Services ► Mobile
      2. Create a WS Token for one user on the site:
        • Click on Site administration ► Plugins ► Web services ► Manage tokens
      3. Go to Site administration ►Mobile app ►Mobile features - Disabled features option
      4. Select the "Blog" optios under the "User" section
      5. Open a terminal/console and execute the following command:
        • You need to replace the wstoken with the token created in step 2 and the URL of your moodle instance

          curl 'http://localhost/m/stable_master/webservice/rest/server.php?moodlewsrestformat=json' --data 'wsfunction=tool_mobile_get_config&wstoken=3af67232a7596ceb658df4db329e5ad6&section=mobileapp' | python -m "json.tool"

      6. Check that in the WS response, in the tool_mobile_disabledfeatures value field, you see the following value: "CoreUserDelegate_AddonBlog:blogs"
      Show
      Enable "Mobile services": Plugins ► Web Services ► Mobile Create a WS Token for one user on the site: Click on Site administration ► Plugins ► Web services ► Manage tokens Go to Site administration ►Mobile app ►Mobile features - Disabled features option Select the "Blog" optios under the "User" section Open a terminal/console and execute the following command: You need to replace the wstoken with the token created in step 2 and the URL of your moodle instance curl 'http://localhost/m/stable_master/webservice/rest/server.php?moodlewsrestformat=json' --data 'wsfunction=tool_mobile_get_config&wstoken=3af67232a7596ceb658df4db329e5ad6&section=mobileapp' | python -m "json.tool" Check that in the WS response, in the tool_mobile_disabledfeatures value field, you see the following value: "CoreUserDelegate_AddonBlog:blogs"
    • Affected Branches:
      MOODLE_36_STABLE
    • Fixed Branches:
      MOODLE_37_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-65423-master

      Description

      There is an incorrect element value in the "Disabled features" option within the Mobile administration options.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jleyva Juan Leyva
                Reporter:
                jleyva Juan Leyva
                Peer reviewer:
                Albert Gasset
                Integrator:
                Eloy Lafuente (stronk7)
                Tester:
                Eloy Lafuente (stronk7)
                Participants:
                Component watchers:
                Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  20/May/19

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 35 minutes
                  35m