Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-65462

Unexpected output with solr search engine

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.6, 3.7
    • Fix Version/s: None
    • Component/s: Global search, Unit tests
    • Labels:
      None
    • Affected Branches:
      MOODLE_36_STABLE, MOODLE_37_STABLE

      Description

      This has started to happen recently in my laptop, when for sure it did not happen before:

      https://pastebin.com/aMKkNADr

      The 29 tests end with 29 + 29 "* Closing connection 0" messages.

      Reproduced with PHP 7.1 and 7.3. And against all branches, so it's not new.

      To reproduce (or no), just run:

      vendor/bin/phpunit -v search/engine/solr/tests/engine_test.php 
      

      Surely it's some local glitch caused by some updated package here... so not critical. But as far as I've not been able to find any cause, I'm reporting this just in case it happens to anybody else.

      Maybe it's the solr extension together with the curl lib it's compiled or something like that (as far as the "closing connection 0" seems to come from curl). In any case, not php problem (or phpunit would cry), but extensions one.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              stronk7 Eloy Lafuente (stronk7)
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: