Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-65616

"Contact request send" message not displayed

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.6, 3.7, 3.10.1
    • Fix Version/s: 3.11
    • Component/s: Messages
    • Labels:
    • Testing Instructions:
      Hide
      1. Login as admin
      2. Create a new user
      3. Navigate to Messaging > Messaging settings in site administration
      4. Enable Allow site-wide messaging
      5. Open messaging drawer
      6. Search for new user
      7. Send them a message
      8. Open the 3-dot menu for the user
      9. Press Add to contacts and confirm the subsequent dialogue
      10. Confirm you see the "Contact request sent" message
      Show
      Login as admin Create a new user Navigate to Messaging > Messaging settings in site administration Enable Allow site-wide messaging Open messaging drawer Search for new user Send them a message Open the 3-dot menu for the user Press Add to contacts and confirm the subsequent dialogue Confirm you see the "Contact request sent" message
    • Affected Branches:
      MOODLE_310_STABLE, MOODLE_36_STABLE, MOODLE_37_STABLE
    • Fixed Branches:
      MOODLE_311_STABLE
    • Pull 3.11 Branch:
      MDL-65616-311
    • Pull Master Branch:

      Description

      The "Contact request send" message is not displayed when it's sent after sending a message.

      Steps to reproduce:

      1. Login as admin
      2. Go to "Site administration / Messaging / Messaging settings" and enable "Allow site-wide messaging"
      3. Open the message drawer and search for any non-contact user
      4. Click any of the non-contact users in the search results
      5. Send a message
      6. Click the 3-dot menu right of the heading showing user s1
      7. Click add to contacts
      8. On the confirmation dialogue click Add

       

      Expected behaviour: The "Contact request send" message should be displayed

      Current behaviour: The "Contact request send" message is not displayed (it still has the "hidden" class).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              pholden Paul Holden
              Reporter:
              sarjona Sara Arjona (@sarjona)
              Peer reviewer:
              Carlos Escobedo Carlos Escobedo
              Integrator:
              Sara Arjona (@sarjona) Sara Arjona (@sarjona)
              Tester:
              Gladys Basiana Gladys Basiana
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                17/May/21

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 hours, 3 minutes
                  2h 3m