Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-65723

When running on PHP 7.3.3, MOODLE 3.7+ fails to load themes if 'themedesignermode' is ON

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 3.7
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None
    • Affected Branches:
      MOODLE_37_STABLE

      Description

      I had a 3.5+ installation that I wanted to upgrade to 3.7+. This installation was using PHP 7.3.3 and worked fine, however after the upgrade the new version fails to load theme (any of them)...

      Do not see any problem with the site functionality otherwise...

      There are hundred of errors like this in the browser:

      http://dev-peter/moodle-latest/theme/styles_debug.php?theme=aardvark&type=plugin&subtype=qtype_calculated net::ERR_ABORTED 500 (Internal Server Error)

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            kepeter Peter Eliyahu Kornfeld
            Participants:
            Component watchers:
            Bas Brands
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: