Moodle
  1. Moodle
  2. MDL-6577

Upgrade settings broken in admin interface

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7
    • Component/s: Administration
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE
    • Rank:
      28305

      Description

      The handling of default values in output_html() is broken for most admin_setting subclasses. The problem manifests itself in upgradesettings.php script, the default values are not displayed there which is a showstopper for upgrades from pre 1.7 releases.

      I will commit partial patch today, please review the changes and fix the rest of classes. This bug is related to MDL-6440 .

        Issue Links

          Activity

          Hide
          Martin Dougiamas added a comment -

          Vince, can you let us know if you are working on this?

          Show
          Martin Dougiamas added a comment - Vince, can you let us know if you are working on this?
          Hide
          Vincenzo K. Marcovecchio added a comment -

          Looking into it.

          Show
          Vincenzo K. Marcovecchio added a comment - Looking into it.
          Hide
          Vincenzo K. Marcovecchio added a comment -

          Martin, Petr,

          I've proposed something for MDL-6440 (which has to be solved before this can be solved). Let me know if it looks alright. If so, I'll implement the fixes for both bugs tonight.

          Show
          Vincenzo K. Marcovecchio added a comment - Martin, Petr, I've proposed something for MDL-6440 (which has to be solved before this can be solved). Let me know if it looks alright. If so, I'll implement the fixes for both bugs tonight.
          Hide
          Vincenzo K. Marcovecchio added a comment -

          See latest changes to lib/adminlib.php

          Hopefully this fully resolves the bug

          (it's tricky to do complete upgrade testing)

          Show
          Vincenzo K. Marcovecchio added a comment - See latest changes to lib/adminlib.php Hopefully this fully resolves the bug (it's tricky to do complete upgrade testing)

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: