Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-66010

Atto text editor- Bold option does not consistently work on Headings

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.5.5, 3.5.6, 3.6, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.7
    • Fix Version/s: None
    • Component/s: HTML Editor (Atto)
    • Labels:
      None
    • Affected Branches:
      MOODLE_35_STABLE, MOODLE_36_STABLE, MOODLE_37_STABLE

      Description

      When any of the Headings are selected as the font style, the attotext editor does add the bold tag correctly to the text and the bold button is clicked, but the headings are not bolded.

       

      While the atto text editor does add the proper bold tags to the selected text, the text does not bold unless a second set of bold tags is set around the text. Attached images document this.

       

      Steps to replicate this issue:

      1. Open any activity that uses the Atto text editor. 
      2. Type heading title
      3. Select the heading size drop down menu
      4. Click the bold icon
      5. Heading is not bold
      6. Check HTML code using the <> in the text editor toolbar
      7. Confirm that <b>HEADING</b> has been added properly
      8. Add additional bold tags to make the heading bolded, text should read <b><b>HEADING</b></b>

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              thomasriva Thomas Riva
              Participants:
              Component watchers:
              Andrew Nicols, Mathew May, Michael Hawkins, Shamim Rezaie, Simey Lameze
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: