Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-66152

CLI upgrade errors 'ru' lang

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.1 regressions, 3.2 regressions
    • Fix Version/s: None
    • Component/s: Administration, Language
    • Labels:
      None

      Description

      Screenplay

       

      ./moodle# sudo -u www-data php5.6 admin/cli/maintenance.php --enable
      ./moodle# sudo -u www-data php5.6 admin/cli/upgrade.php
      == Обновление базы данных Moodle с версии 3.1.2+ (Build: 20160929) (2016052302.04) до 3.2.8+ (Build: 20180515) (2016120508.03) ==
      Файлы Moodle изменены, можно приступить к
      автоматическому обновлению сервера до
      следующей версии:
      3.2.8+ (BUILD: 20180515) (2016120508.03).
      Если Вы сделаете это, то не сможете
      вернуться назад. Учтите, что этот процесс
      может занимать много времени.
      Вы уверены, что хотите обновить сервер до
      этой версии?
      Введите y (обозначает Да) или n (обозначает Нет)
      : y
      Некорректное значение, пожалуйста, попробуйте заново
      Введите y (обозначает Да) или n (обозначает Нет)
      : Y
      Некорректное значение, пожалуйста, попробуйте заново
      Введите y (обозначает Да) или n (обозначает Нет)
      : y
      Некорректное значение, пожалуйста, попробуйте заново
      Введите y (обозначает Да) или n (обозначает Нет)
      : Да
      Некорректное значение, пожалуйста, попробуйте заново
      Введите y (обозначает Да) или n (обозначает Нет)
      : да 
      -->Процедура импорта языка: ru
      ++ Языковой пакет «ru» успешно установлен ++
      -->Система
      ++ Успешно ++
      -->antivirus_clamav
      ++ Успешно ++
      -->availability_completion
      ++ Успешно ++
      -->logstore_standard
      ++ Успешно ++
      Обновление из командной строки успешно завершено.
      

       

      Before: ++ Языковой пакет «ru» успешно установлен ++

      Lang OLD version cache existing (Strings for component 'admin', language 'ru', branch 'MOODLE_31_STABLE')

      %dataroot%/lang/ru

      After: ++ Языковой пакет «ru» успешно установлен ++

      Lang version updated (Strings for component 'admin', language 'ru', branch 'MOODLE_32_STABLE')
      %dataroot%/lang/ru

       

      Solution 1:

      Incorrect values:

      $string['clianswerno'] = 'нет';
      $string['cliansweryes'] = 'да';

      Correct values:

      $string['clianswerno'] = 'n';
      $string['cliansweryes'] = 'y';

      Solution 2:

      Incorrect values:

      $string['cliyesnoprompt'] = 'Введите y (обозначает Да) или n (обозначает Нет)';
      $string['clianswerno'] = 'нет';
      $string['cliansweryes'] = 'да';

      Correct values:

      $string['cliyesnoprompt'] = 'Введите д (обозначает Да) или н (обозначает Нет)';
      $string['clianswerno'] = 'н';
      $string['cliansweryes'] = 'д';

       

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              uriy“merkuriy”efremochkin Uriy “MerkUriy” Efremochkin
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, cameron1729, David Mudrák (@mudrd8mz), Helen Foster
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: