Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-66184

Bump moodle-behat-extension php requirements to 7.x

    XMLWordPrintable

    Details

    • Story Points:
      0
    • Sprint:
      Internationals - 3.8 Sprint 5, Internationals - 3.8 Sprint 6

      Description

      In MDL-50733 we updated moodle-behat-extension to newer behat version (3.5) and updated other requirements.

      This is a followup about to, also, raise the php required version to 7.0 (35_STABLE and 36_STABLE) and 7.1 (37_STABLE and master).

      Steps should be:

      1) Create the PRs @ github.
      2) Run tests @ CI agains them.
      3) Merge the PRs and release the new versions.
      4) Bump composer here to point to the new releases.

      Doc: https://docs.moodle.org/dev/Composer#How_to_prepare_and_submit_composer_changes

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  9/Sep/19

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 6 hours, 30 minutes
                  6h 30m