Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-66272

Custom theme favicon on LTI provider site breaks LTI authentication

    XMLWordPrintable

Details

    • MOODLE_35_STABLE, MOODLE_36_STABLE, MOODLE_37_STABLE
    • MOODLE_36_STABLE, MOODLE_37_STABLE
    • MDL-66272-master
    • Hide

      Confirm that the documentation for the favicon method in the class core_renderer (lib/outputrenderers.php) clearly specifies that it returns a moodle_url object.

      Show
      Confirm that the documentation for the favicon method in the class core_renderer  (lib/outputrenderers.php) clearly specifies that it returns a moodle_url object.
    • Moppies Moodle 3.8 Sprint 4

    Description

      This report stems from the discussion at https://moodle.org/mod/forum/discuss.php?d=371252

      Problem: If a favicon is added through a custom theme setting on the provider site, LTI authentication doesn't work. 

      A technical description of the issue can be read here: https://moodle.org/mod/forum/discuss.php?d=371252

       

      Attachments

        Activity

          People

            vmdef Victor Déniz Falcón
            cb526 cb526
            Carlos Escobedo Carlos Escobedo
            Jun Pataleta Jun Pataleta
            Jun Pataleta Jun Pataleta
            David Woloszyn, Huong Nguyen, Jake Dallimore, Meirza, Michael Hawkins, Raquel Ortega, Safat Shahin, Stevani Andolo, Huong Nguyen, Bas Brands, Mathew May
            Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              9/Sep/19

              Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 hour, 1 minute
                1h 1m