Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.6.2
    • Fix Version/s: 1.7
    • Component/s: Lesson
    • Labels:
      None
    • Environment:
      local host XP Pro OS, MYSQL, Apache, Foxfile, turned on debug in admin settings.
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE
    • Rank:
      28279

      Description

      Not sure how serious this is. First time I have turned on debug.

      Downloaded new complete package. Admin says Moodle 1.6.2+ (2006050521). Changed a few settings in my first lesson. and said yes to use this as a template. I first saw 5 lines of error code. Good news is that it seems to have saved the lesson settings when I created a second lesson.

      Here is what flashed.

      Notice:Undefined Property: stdClass:$name in G:\xampplite\moodle\mod\lesson\lib.php on line 191.

      similar for $name on line 192
      similar for $available on line 199
      similar for $deadline on line 201
      similar for $available on line 201

        Activity

        Hide
        Chris Collman added a comment -

        Not a good subject line, thought it had failed because of debug error.

        Show
        Chris Collman added a comment - Not a good subject line, thought it had failed because of debug error.
        Hide
        Mark Nielsen added a comment -

        Should be fixed in CVS HEAD. Thanks for the report Chris!

        Show
        Mark Nielsen added a comment - Should be fixed in CVS HEAD. Thanks for the report Chris!
        Hide
        Chris Collman added a comment -

        closed a long time ago, sorry

        Show
        Chris Collman added a comment - closed a long time ago, sorry

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: