Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-66331

Unable to use latest Python machine learning backend in 3.7

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 3.7.1
    • Fix Version/s: None
    • Component/s: Analytics
    • Affected Branches:
      MOODLE_37_STABLE

      Description

      When I selet "Python machine learning backend" on /admin/settings.php?section=analyticssettings, it shows errors as below:

      The selected predictions processor is not ready: "moodlemlbackend" python package is not installed or there is a problem with it. Please execute "/usr/bin/python -m moodlemlbackend.version" from command line interface for more info

       

      However, I run in my server:

      haha@moodle:~$ /usr/bin/python -m moodlemlbackend.version
      1.0.0

       

      I installed the python packages as the instructions "pip install "moodlemlbackend>=1.0.0,<2.0.0"" [here|https://docs.moodle.org/37/en/Analytics_settings]. My box is Ubuntu 18.04 64bit.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              fishfree fishfree
              Participants:
              Component watchers:
              Elizabeth Dalton, David Monllaó
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: