Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-66580

Intermittent failures when running ClamAV using Unix domain socket

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.7.1
    • Fix Version/s: None
    • Component/s: Antivirus, Filepicker
    • Labels:
    • Affected Branches:
      MOODLE_37_STABLE

      Description

      We recently switching from Command line -> Unix domain socket to get better AV scanning performance, which generally works very well.

      However, intermittently (<1% of file uploads) the scanning is failing with a blank error message. We have not yet worked out what the problem is. (So, in part, we want to change the failure emails to include more useful information.)

      This issue is to track this. Hopefully we can add some more useful information soon.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              timhunt Tim Hunt
              Reporter:
              timhunt Tim Hunt
              Participants:
              Component watchers:
              Ruslan Kabalin, Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Sujith Haridasan
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 5 minutes
                  5m