Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-66707

Forum too eager to mark messages as read (threaded view)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.7
    • Fix Version/s: None
    • Component/s: Forum
    • Labels:
    • Testing Instructions:
      Hide

      Steps to reproduce (works as expected on M3.5):
       
      User 1:

      • Create a forum, start a discussion, set "Display replies in threaded form"

      User 2:

      • Reply to the first post, and reply to that reply.

      User 1:

      • Expected behaviour on M3.7 (actual behaviour on M3.5):
        • View the Forum page, showing Replies=2, Unread=2.
        • View the discussion, showing the text of the first post, and a highlighted link to each reply.
        • Click the link for the first reply, showing the text of the first reply, and a highlighted link the second reply.
        • Click "Show parent" to go back to the first post, where the second reply link is still highlighted. * View the Forum page, showing Replies=2, Unread=1.
      • Actual behaviour on M3.7:
        • View the Forum page, showing Replies=2, Unread=2.
        • View the discussion, showing the text of the first post, and non-highlighted links to the replies.
        • Click the link for the first reply, showing the text of the first reply, and a non-highlighted link to the second reply.
        • Click "Show parent" to go back to the first post, where the neither reply link is highlighted. * View the Forum page, showing Replies=2, Unread=0.

           
           
      Show
      Steps to reproduce (works as expected on M3.5):   User 1: Create a forum, start a discussion, set "Display replies in threaded form" User 2: Reply to the first post, and reply to that reply. User 1: Expected behaviour on M3.7 (actual behaviour on M3.5): View the Forum page, showing Replies=2, Unread=2. View the discussion, showing the text of the first post, and a highlighted link to each reply. Click the link for the first reply, showing the text of the first reply, and a highlighted link the second reply. Click "Show parent" to go back to the first post, where the second reply link is still highlighted. * View the Forum page, showing Replies=2, Unread=1. Actual behaviour on M3.7: View the Forum page, showing Replies=2, Unread=2. View the discussion, showing the text of the first post, and non-highlighted links to the replies. Click the link for the first reply, showing the text of the first reply, and a non-highlighted link to the second reply. Click "Show parent" to go back to the first post, where the neither reply link is highlighted. * View the Forum page, showing Replies=2, Unread=0.    
    • Affected Branches:
      MOODLE_37_STABLE

      Description

      Having set forum view mode to "Display replies in threaded form", forum replies are displayed as nested links that must be followed to view the replies.

      In M3.5 (and I guess probably M3.6), the replies would not be marked as read until clicked and viewed.

      In M3.7, the replies would are marked as read when the thread is loaded - without having viewed them.

      It seems clear that not changing the read status until actually read is the correct behaviour, and this change/regression is a loss of functionality for some of my users.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            balchd Dave Balch
            Participants:
            Component watchers:
            Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: