Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-67281

Incorrect 'last post' dates on forum page

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.8
    • Fix Version/s: 3.8
    • Component/s: Forum
    • Testing Instructions:
      Hide
      1. Change the server clock (call it T1) backwards some days and create a forum with a few discussions.
      2. Move the clock to current (call it T2) and post a reply to the discussions.
      3. Go to the forum page and examine the discussion list.
      4. Verify:
        1. The "Started by" column shows T1 for all discussions.
        2. The "Last post" column shows T2 for all discussions.
        3. The tooltip displayed over the "last post" is also T2 (matches the text).
      5. Move the clock to tomorrow (call it T3).
      6. Go to ONE of the discussions and post another reply. Remember which discussion is.
      7. Go to the forum page and examine the discussion list.
      8. Verify:
        1. The "Started by" column shows T1 for all discussions.
        2. The "Last post" column shows T3 for the discussion with the new post.
        3. The tooltip displayed over the "last post" is also T3 (matches the text) for that discussion.
        4. All the other discussions continue showing "Last post" T2. Like they were in 4) above.
      Show
      Change the server clock (call it T1) backwards some days and create a forum with a few discussions. Move the clock to current (call it T2) and post a reply to the discussions. Go to the forum page and examine the discussion list. Verify : The "Started by" column shows T1 for all discussions. The "Last post" column shows T2 for all discussions. The tooltip displayed over the "last post" is also T2 (matches the text). Move the clock to tomorrow (call it T3). Go to ONE of the discussions and post another reply. Remember which discussion is. Go to the forum page and examine the discussion list. Verify : The "Started by" column shows T1 for all discussions. The "Last post" column shows T3 for the discussion with the new post. The tooltip displayed over the "last post" is also T3 (matches the text) for that discussion. All the other discussions continue showing "Last post" T2. Like they were in 4) above.
    • Affected Branches:
      MOODLE_38_STABLE
    • Fixed Branches:
      MOODLE_38_STABLE
    • Pull Master Branch:

      Description

      As reported by Séverin Terrier in the discussion Moodle.org now running on Moodle 3.8, the "Started by" column on the forum page e.g. https://moodle.org/mod/forum/view.php?id=7135 doesn't show the date the discussion was started. It shows the same date as in the "Last post" column.

        Attachments

          Activity

            People

            Assignee:
            stronk7 Eloy Lafuente (stronk7)
            Reporter:
            tsala Helen Foster
            Peer reviewer:
            David Mudrák (@mudrd8mz)
            Integrator:
            Jun Pataleta
            Tester:
            Jun Pataleta
            Participants:
            Component watchers:
            Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              18/Nov/19

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 hour, 56 minutes
                1h 56m