Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-67304

Analytics: missing icon when font-awesome not in use.

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 3.8
    • 3.8.1
    • Analytics
    • MOODLE_38_STABLE
    • MOODLE_38_STABLE
    • MDL-67304_master
    • Hide
      1. Log in as admin
      2. Disable onlycli in "Site admin > analytics > analytics settings"
      3. Create a new course with start date 2 weeks ago
      4. Add 1 student with "Starting from" = "Course start"
      5. Go to "Site admin > analytics > analytics models"
      6. Click on "Actions > Edit" for the "Students who have not accessed the course yet" model
      7. Select "One week after start" for the "Analysis interval" field and save changes
      8. Click on "Actions > Execute scheduled analysis" for the same model and click on continue to return to the models list page
      9. Select the course you just created from the dropdown menu
      10. Comment out the last line (where THEME->iconsystem is defined) in theme/boost/config.php
      11. The "Incorrectly flagged" button should look like this:
      Show
      Log in as admin Disable onlycli in "Site admin > analytics > analytics settings" Create a new course with start date 2 weeks ago Add 1 student with "Starting from" = "Course start" Go to "Site admin > analytics > analytics models" Click on "Actions > Edit" for the "Students who have not accessed the course yet" model Select "One week after start" for the "Analysis interval" field and save changes Click on "Actions > Execute scheduled analysis" for the same model and click on continue to return to the models list page Select the course you just created from the dropdown menu Comment out the last line (where THEME->iconsystem is defined) in theme/boost/config.php The "Incorrectly flagged" button should look like this:

    Description

      https://github.com/moodle/moodle/blob/master/analytics/classes/default_bulk_actions.php#L79

      If font-awesome not in use you get a broken image because there isn't an image called "incorrect" in the pix/i folder.

       

       

      Attachments

        Activity

          People

            dmonllao David Monllaó
            danmarsden Dan Marsden
            Dan Marsden Dan Marsden
            Jake Dallimore Jake Dallimore
            Gladys Basiana Gladys Basiana
            Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Laurent David, Sara Arjona (@sarjona)
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              13/Jan/20

              Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 50 minutes
                50m