Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-67380

Upgrade GeoIP2 and MaxMind DB reader to latest version

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Check third pary lib versions in site administration and make sure Geoip is 2.10.0 and Maxmind is 1.5.1
      2. Run unit tests on iplookup/tests/geoip_test.php with PHPUNIT_LONGTEST defined. File has two tests, both should be executed and pass.
      Show
      Check third pary lib versions in site administration and make sure Geoip is 2.10.0 and Maxmind is 1.5.1 Run unit tests on iplookup/tests/geoip_test.php with PHPUNIT_LONGTEST defined. File has two tests, both should be executed and pass.
    • Affected Branches:
      MOODLE_38_STABLE
    • Fixed Branches:
      MOODLE_39_STABLE
    • Epic Link:
    • Pull from Repository:
    • Pull Master Branch:
      MDL-67380-master
    • Sprint:
      Moodle 3.9 - Moppies Kanban

      Description

      GeoIP2 PHP API /lib/maxmind/GeoIp2/ 2.9.0 --> 2.10.0: https://github.com/maxmind/GeoIP2-php/releases

      MaxMind DB Reader API (/lib/maxmind/MaxMind/) 1.4.1 --> 1.5.1: https://github.com/maxmind/MaxMind-DB-Reader-php/releases 
       

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/May/20

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 6 hours
                  6h