This was raised when reviewing
When viewing or editing role definitions (Admin -> Users -> Permissions -> Define roles) capabilities are show together under a heading line with the name of the plugin, so you can easily identify to which component they belong to.
This is under the control of the get_component_string() function (accesslib).
Right now that function prefixes the plugin name with the name of the plugin type for some plugins (mods, blocks, webservices...) so you get headings like:
- Activity: Glossary
- Block: Latest badges
- Repository: File system
But the default behavior for lots of plugin types is to show only the plugin name, without any prefix:
- Course participation.
- Course completion.
- IMS Enterprise file.
- Publish as LTI tool
And, that can be confusing (those plugins can be anything, a report, a tool, a enrol method... anything).
This issue is about to decide if we should add the prefix to more (or to all) plugin types or no. IMO that would make them clearer and more consistent.
Not the end of the world, but a little improvement for capabilities belonging to plugins.
For your consideration, ciao