Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-67501

3.5 to 3.8 fail on Plugin "block/etc"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 3.8
    • Fix Version/s: None
    • Component/s: Blocks
    • Labels:
      None
    • Affected Branches:
      MOODLE_38_STABLE

      Description

      ******Resolved issues by upgrading from 3.8 to 3.8+ as 3.8 is missing version.php files from several core files.*******

      While updating form 3.5 to 3.8; i am stuck that the below error?
      I haven't been able to find anything helpful on how to resolve this.

      Plugin "block/etc" is defective or outdated, can not continue, sorry.

      More information about this error

      ×Debug info: Missing version.php file.
      Error code: detectedbrokenplugin
      ×Stack trace:
      line 900 of /lib/upgradelib.php: plugin_defective_exception thrown
      line 534 of /lib/upgradelib.php: call to upgrade_plugins_blocks()
      line 1877 of /lib/upgradelib.php: call to upgrade_plugins()
      line 694 of /admin/index.php: call to upgrade_noncore()

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            jstiner Jason
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Sujith Haridasan
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: