Currently, in the code in charge of block deletion, it's allowed to have TWO types of table names so, for the block XYZ is possible to have both:
1) mdl_XYZ... tables and
2) mdl_block_XYZ... tables
Following http://docs.moodle.org/en/Development:Coding#Database_structures rules, only the 2nd alternative should be possible (to avoid potential block-module name conflicts and so on). But this could break compatibility with some 3rd part blocks that are using the 1st alternative (attendance, shared_files, timetracker...).
So, for 1.7 we'll allow both naming schemas to coexist but for 2.0 only the 2nd will survive.