Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-6796

Welcome and other system emails from noreply address

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Deferred
    • Affects Version/s: 1.6.2, 2.2.1
    • Fix Version/s: None
    • Component/s: Administration
    • Labels:
    • Database:
      Any
    • Affected Branches:
      MOODLE_16_STABLE, MOODLE_22_STABLE

      Description

      I would like the course welcome emails sent out from the noreplly address.

      Some might want to keep their email address private.

      My reason is that my university server only sends out emails with send addresses set to the university domain but I want to set the admin email to another domain.

      It would be nice to be able to set all system emails (if any more are coming from the administrator) to be sent from the no reply address, or another settable address, not that of the administrator.

      Tim

        Gliffy Diagrams

          Issue Links

            Activity

            starfish Linda B. added a comment -

            I too would appreciate the ability to set the admin address of certain emails. I am the sole administrator on a Moodle 1.6.1 site. Whenever an email goes out to the students (for password change, confirm account, etc.) it usually says if there is a problem to contact the site admin at my email address. However, I am running the site for someone else, and he wants the students to contact him not me. I need to change the contact admin addresses on these student emails to his address. I don't want him to have any admin privileges, I just want the student emails to refer to his email address for help.

            libertymoodle Luis de Vasconcelos added a comment -

            Four years later, I'm pinging this instead of raising a new issue. I've been asked for this function by my administrators quite a few times - and they won't take no for an answer!

            libertymoodle Luis de Vasconcelos added a comment -

            I'm linking to this issue as they are both quite similar - both refer to having Moodle send e-mails from a noreply address.

            timhunt Tim Hunt added a comment -

            Michel, could you please triage this bug appropriately.

            At the moment, all these email are sent using $from = get_admin(); hard-coded everywhere (which has its own problems. See MDL-31559).

            I suggest a new helper function, something like get_system_email_sender() to make the API clear, and to make it possible to fix future bugs like this in one place.

            (Note that this is different from what you do to send an email from the noreply address.)

            andyjdavis Andrew Davis added a comment -

            Im closing this. For MDL-25476 I've switched these notifications from the admin to the support contact. As part of MDL-31560 we can look at extending the messaging system to give the option to send from a noreply address.

            timhunt Tim Hunt added a comment -

            I would have thought it was better to resolve this duplicate of MDL-25476, rather than Won't-fix.

            salvetore Michael de Raadt added a comment -

            I'm closing this as deferred as it is being resolved in another issue.


              People

              • Votes:
                4 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: