Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-67960

Question bank: tag filtering UI is *very* slow to load, and other JS does not work until it has

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.7.4, 3.8.1
    • Fix Version/s: None
    • Component/s: Questions, Tags
    • Labels:
    • Affected Branches:
      MOODLE_37_STABLE, MOODLE_38_STABLE

      Description

      Steps to reproduce:

      1. Set your Moodle to be suitable for development. (E.g. turn of cache JS.)
      2. Go to the question bank.
      3. Click "Create a new question"

      Expected result: the dialogue opens where you can select the question type you want.

      Acutal result: You get to an error page saying "You must select a question type."

      The reason is that the 'filter by tags' UI had not fnished initialising itself. And, for some reason, this blocks all the other JS on the page from initialising itself.

      Either the tags JS needs to be sped up massively, or it needs to not block other JS.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            timhunt Tim Hunt
            Participants:
            Component watchers:
            Tim Hunt, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated: