Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-67986

Atto paste leaves input point at the start of the new content, not the end

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.7.4, 3.8.1
    • Fix Version/s: None
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Copy the URL https://moodle.org/ to your clipboard.
      2. Start writing a forum post.
      3. Type 'The forums at CRTL+V are a good place to get help with Moodle.'

      Expected result: The editor should contain "The forums at https://moodle.org/ are a good place to get help with Moodle."

      Actual result "The forums at are a good place to get help with Moodle.https://moodle.org/" because when you pasted, the text input point ended up at the start of where you pasted, not the end.

      (I saw this in Firefox. Not sure if it is browser-dependent.)

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              timhunt Tim Hunt
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Barbara Ramiro, Bas Brands
              Votes:
              10 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated: