Moodle
  1. Moodle
  2. MDL-6857

Forbid any upgrade in 1.8 if the DB hasn't been migrated to UTF-8

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8
    • Component/s: Installation
    • Labels:
      None
    • Environment:
      Any
    • Database:
      Any
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      Exactly after 1.7 branching we MUST forbid any upgrade in HEAD if the UTF-8 migration hasn't been executed (i.e. $CFG->unicodedb != true).

      With this:

      • all the moodlers trying to upgrade to 1.8 will have to migrate before.
      • we'll be able to drop utf-8 migration support (MDL-6332)

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Eloy Lafuente (stronk7) added a comment -

            Adding dependency

            Show
            Eloy Lafuente (stronk7) added a comment - Adding dependency
            Hide
            Martin Dougiamas added a comment -

            Done in 1.8. Admins get a message telling them to upgrade to 1.7.x first.

            Show
            Martin Dougiamas added a comment - Done in 1.8. Admins get a message telling them to upgrade to 1.7.x first.
            Hide
            Eloy Lafuente (stronk7) added a comment -

            Is Working. Closing this subtask now.

            Show
            Eloy Lafuente (stronk7) added a comment - Is Working. Closing this subtask now.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: