Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-68618

Forum idnumber update not working

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Login as admin
      2. Create a course
      3. Add a forum activity
      4. Navigate to your new forum
      5. From the Actions menu select Edit settings
      6. Expand Common module settings
      7. Set ID number to "FOO"
      8. Press Save and display
      9. From the Actions menu select Edit settings
      10. Expand Common module settings
      11. Confirm ID number still equals "FOO"
      12. Set ID number to "BAR"
      13. Press Save and display
      14. From the Actions menu select Edit settings
      15. Expand Common module settings
      16. Confirm ID number still equals "BAR"
      Show
      Login as admin Create a course Add a forum activity Navigate to your new forum From the Actions menu select Edit settings Expand Common module settings Set ID number to "FOO" Press Save and display From the Actions menu select Edit settings Expand Common module settings Confirm ID number still equals "FOO" Set ID number to "BAR" Press Save and display From the Actions menu select Edit settings Expand Common module settings Confirm ID number still equals "BAR"
    • Affected Branches:
      MOODLE_38_STABLE, MOODLE_39_STABLE
    • Fixed Branches:
      MOODLE_38_STABLE, MOODLE_39_STABLE
    • Pull 3.9 Branch:
    • Pull Master Branch:

      Description

      Related to this Issue: MDL-68603

      Using Moodle 3.8.2+ is not possible to update a existent forum idnumber by using the form at the URL https://mymoodledomain.com/course/modedit.php?update=<forum-id>&return=1

      No errors are raised, so I think the update code is not considering this field as other fields are being saved correctly.

       

      Steps to reproduce:

      1. Create a new forum
      2. Let the idnumber empty
      3. Update the forum and set a idnumber
      4. Check to see if it was saved

      I did a clean install, my environment is (everything updated):

      • Ubuntu 18.04
      • Nginx
      • PHP-FPM 7.2
      • Mysql 5.7
      • Moodle 3.8.2+ (latest)

        Attachments

        1. 01-forum-create.png
          01-forum-create.png
          86 kB
        2. 02-no-idnumber.png
          02-no-idnumber.png
          44 kB
        3. 03-update.png
          03-update.png
          47 kB
        4. 04-not-saved.png
          04-not-saved.png
          44 kB
        5. 05-blank-value.png
          05-blank-value.png
          9 kB
        6. image-2020-08-12-14-28-47-088.png
          image-2020-08-12-14-28-47-088.png
          71 kB

          Issue Links

            Activity

              People

              Assignee:
              pholden Paul Holden
              Reporter:
              minholi Marcelo Minholi
              Peer reviewer:
              Mihail Geshoski Mihail Geshoski
              Integrator:
              Andrew Lyons Andrew Lyons
              Tester:
              Janelle Barcega Janelle Barcega
              Participants:
              Component watchers:
              Andrew Lyons, Dongsheng Cai, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                14/Sep/20

                  Time Tracking

                  Estimated:
                  Original Estimate - 0 minutes
                  0m
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 hours, 35 minutes
                  2h 35m