Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-68735

Add environment check for versions >= 7.5

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.8.3, 3.9
    • Fix Version/s: None
    • Component/s: General, Installation
    • Labels:
      None
    • Affected Branches:
      MOODLE_38_STABLE, MOODLE_39_STABLE

      Description

      PHP 7.4 is supported from Moodle 3.8.

      The next version of PHP will be 8.0.

      We should introduce a restricted PHP version check for PHP versions >= 7.5 into 3.8 and up.

      We should really have done this when we removed the 7.4 restricted version check as we always knew that 7.4 was the benchmark, and not a higher version.

      I feel it's better to make this change now, and not when 8.0 is out because some people will not update Moodle in the interim.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            dobedobedoh Andrew Nicols
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Matteo Scaramuccia, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: