Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-68739

Course not backed up with CLI script

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Not a bug
    • 3.9
    • None
    • Backup
    • MOODLE_39_STABLE
    • 1
    • Path to glory

    Description

      As reported by Anna Sadia in MDLQA-14676:

      Steps to reproduce:

      1. Log in as an administrator.
      2. Create a test course,'course1'.
      3. Go to Site administration > Courses > Backups > Automated backup setup.
      4. Ensure under Automated backup setup, Active (backup_auto_active) is set to Enabled.
      5. Ensure under Automated backup setup, Skip courses not modified since previous backup (backup_auto_skip_modif_prev) is checked (enabled).
      6. In your site's wwwroot, run: php admin/cli/automated_backups.php

      Expected result: The backup runs to completion, and includes the following in the output: "Backing up coursexx...".

      Actual result: "Backing up coursexx" is not reflected in the output.

      Attachments

        Issue Links

          Activity

            People

              mudrd8mz David Mudrák (@mudrd8mz)
              tsala Helen Foster
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Sujith Haridasan
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 10 minutes
                  10m