Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-68964

Swapping theme in chat window causing notice error

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Activate debug using the command: mdk run mindev
        1. Alternative set the debug level to developer and enable display debug messages.
      2. Go to "site administration -> appearance -> Themes -> Theme settings" and enable "Allow theme changes in the URL"
      3. Create a course with a chat activity
      4. Access the chat activity and click on the "Click here to enter the chat now" link
      5. On the popup window click on themes and switch the theme to "Bubble"
        1. Check that no warning appears while reloading
      6. Repeat step 5 three using a different theme each time
        1. Check that no warning appears while loading.
      Show
      Activate debug using the command: mdk run mindev Alternative set the debug level to developer and enable display debug messages. Go to "site administration -> appearance -> Themes -> Theme settings" and enable "Allow theme changes in the URL" Create a course with a chat activity Access the chat activity and click on the "Click here to enter the chat now" link On the popup window click on themes and switch the theme to "Bubble" Check that no warning appears while reloading Repeat step 5 three using a different theme each time Check that no warning appears while loading.
    • Affected Branches:
      MOODLE_38_STABLE, MOODLE_39_STABLE
    • Fixed Branches:
      MOODLE_38_STABLE, MOODLE_39_STABLE
    • Pull 3.9 Branch:
    • Pull Master Branch:
      MDL-68964-master
    • Sprint:
      Moppies Kanban

      Description

      Testing for 3.9 QA, noticed the following, and also applies to 3.8, with https://sandbox.moodledemo.net.

      In the Chat window, when the teacher or student swaps their theme, (Bubble, Compact, Course theme), a page error appears for a few moments then disappears with the page reload:

      "This page should be using theme course_theme which cannot be initialised. Falling back to the site theme boost"
      <ul style="text-align: left" data-rel="backtrace"><li>line 686 of /lib/outputlib.php: call to debugging()</li><li>line 838 of /lib/setup.php: call to theme_config::load()</li><li>line 94 of /config.php: call to require_once()</li><li>line 17 of /mod/chat/gui_ajax/index.php: call to require_once()</li></ul></div>

        Attachments

        1. chat_theme_swap_error.png
          37 kB
          Karen Holland
        2. image-2020-08-20-13-44-26-390.png
          35 kB
          Janelle Barcega

          Issue Links

            Activity

              People

              Assignee:
              tusefomal Ferran Recio
              Reporter:
              wuzi1999 Karen Holland
              Peer reviewer:
              Simey Lameze Simey Lameze
              Integrator:
              Adrian Greeve Adrian Greeve
              Tester:
              Janelle Barcega Janelle Barcega
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                14/Sep/20

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 3 hours, 20 minutes
                  3h 20m