Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-69041

Ensure that correct node version is used by travis and that the job fails when expected

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: 3.5.12, 3.7.6, 3.8.3, 3.9, 4.0
    • Fix Version/s: None
    • Component/s: General, Unit tests
    • Labels:
      None
    • Affected Branches:
      MOODLE_35_STABLE, MOODLE_37_STABLE, MOODLE_38_STABLE, MOODLE_39_STABLE, MOODLE_40_STABLE

      Description

      Was performing the 3.9.0 packaging when, looking to changes to .travis.yml realised that we are still using lts/carbon there.

      Also, right now, with that version, the grunt job should be failing and it's not (pretty much that's the reason we haven't detected that earlier).

      So this issue is about both:

      1) Ensure that the grunt job fails when it has to fail (both problems and or detected differences).
      2) Update to current nodejs version.

      Note that, surely, this needs to go to 35 and up (but 36 that is out of support).

      Ciao

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            stronk7 Eloy Lafuente (stronk7)
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated: