Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-69229

Moodle apps subscription page error

    XMLWordPrintable

Details

    • Bug
    • Status: Open
    • Minor
    • Resolution: Unresolved
    • 3.9.1, 3.10
    • None
    • Web Services
    • MOODLE_310_STABLE, MOODLE_39_STABLE

    Description

      1. Log in as admin
      2. Navigate to Site admin -> Mobile app -> Mobile settings
      3. Enable Mobile web services
      4. Save changes
      5. Click on "Moodle app subscription"
        1. Failure: Debugging is shown, but hidden by the header

      In my opinion there are two issues here:

      1. If there are no credentials for the app, then the link should not be shown at all and the page should be hidden; and
      2. the debugging notice is useless because it his hidden behind the header.

      Debugging notice is as below:

      Unexpected response from the Moodle Apps Portal server:{"error":true,"exception":{"message":"error\/These credentials are invalid: sitesubscriptionkey","errorcode":"These credentials are invalid: sitesubscriptionkey","link":"https:\/\/apps.moodle.com\/","moreinfourl":"http:\/\/docs.moodle.org\/38\/en\/error\/moodle\/These credentials are invalid: sitesubscriptionkey"}}<ul style="text-align: left" data-rel="backtrace"><li>line 737 of /admin/tool/mobile/classes/api.php: call to debugging()</li><li>line 40 of /admin/tool/mobile/subscription.php: call to tool_mobile\api::get_subscription_information()</li></ul>
      

      Attachments

        Issue Links

          Activity

            People

              jleyva Juan Leyva
              dobedobedoh Andrew Lyons
              Juan Leyva, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Laurent David, Raquel Ortega, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated: