Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-69531

"Paste and replace" in H5P editor is not working as expected with images

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.9.1
    • Fix Version/s: None
    • Component/s: Content bank, H5P
    • Labels:
    • Affected Branches:
      MOODLE_39_STABLE

      Description

      Steps to reproduce

      1. Login as admin.
      2. Access to the Content bank.
      3. Upload the attached file.
      4. Edit the content and click over the "Copy" button (near "Paste and replace" button).
      5. Access to the main page of the Content bank
      6. Add a new "Greeting card" content.
      7. Click the "Paste and replace" button.

      Expected behaviour

      The content and the image should be displayed properly.

       

      Current behaviour

      The content is pasted but the image doesn't appear in the preview (see attached screenshot). If the content is saved, the image neither appear.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              sarjona Sara Arjona (@sarjona)
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated: