Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-70521

Additional HTML coding in Atto breaks Table of Content creation in Wiki

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.9.3, 3.10
    • Fix Version/s: None
    • Component/s: Wiki (2.x)
    • Labels:
    • Affected Branches:
      MOODLE_310_STABLE, MOODLE_39_STABLE

      Description

      In Moodle 3.9, in a Wiki activity, with HTML editor enabled, it is not possible to automatically create a Table of Contents with the ATTO text formatting header options.

      The headers do appear, but a TOC doesn't display, as can be seen in the screenshots attached.

      To reproduce the issue:

      • Create a course
      • Add a wiki
      • Set the wiki to HTML editor
      • Create a page with at least a large, medium and small header using the ATTO text editor and save
      • Check to see if a TOC appears

      If a TOC doesn't appear, check to see if the HTML contains 'clean' header tags, e.g. <h3></h3>, <h4></h4> or <h5></h5>. You'll see the header tags contain dir and class.

      I found these issues to occur in ATTO using Firefox and Chrome, not in Safari.

      Note: When you directly edit the HTML to remove the dir and class code from a header tag, that may solve part of the issue.

      The TOC creation seems to depend on 'clean' header tags.

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            jwelshoff Joost Elshoff
            Participants:
            Component watchers:
            Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
            Votes:
            4 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated: