Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-70561

Dacast player JavaScript conflicts with require.min.js

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.9.3
    • Fix Version/s: None
    • Component/s: JavaScript
    • Affected Branches:
      MOODLE_39_STABLE

      Description

      A MoodleCloud customer reported the following:

      I try to embed a video on my Moodle instance, but the JavaScript "require.min.js" generate a problem with my video, I need help to fix that problem, thanks for your help

      This Javascript is included on my Moodle installation, here you link of the JavaScript that the DACAST team told is the source of my problem

      <script src="https://ssi.moodle.school/lib/javascript.php/1602649091/lib/requirejs/require.min.js"></script>

      With that script my video does not work, please go to these link

      https://jsfiddle.net/michael_elliott_dacast_com/kegadfm5/18/ (with the script included)

      vs

      https://jsfiddle.net/michael_elliott_dacast_com/kegadfm5/19/ (without the script)

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            cameron1729 cameron1729
            Participants:
            Component watchers:
            Andrew Lyons, Dongsheng Cai, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: