Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-70600

mod_forum: Unable to post in Forum to All participants when using Visible Groups

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Not a bug
    • 3.9.3
    • None
    • Forum
    • None
    • MOODLE_39_STABLE

    Description

      An error message is displayed when user who is a member of a group attempts to Post to a Forum "All participants" when group mode is set to Visible groups.

      Environment:
      Moodle - 3.9.3+ (Build: 20210108)
      Forum - 2020061501

      Replication:

      1. Create a course.
      2. Enrol four (4) student users.
      3. Create two (2) groups and add members
        • groupA - user1
        • groupB - user2, user3, user4
      4. Turn editing on.
      5. Add a Forum activity and set Group mode to Visible groups.
      6. Log in as user1, go to the course and visit the Forum activity.
      7. In the "Visible groups" drop-down control, select "All participants".
        RESULT: The following message is displayed: You are not able to create a discussion because you are not a member of any group.

      Attachments

        Activity

          People

            dobedobedoh Andrew Lyons
            jebarvia Joshua Ebarvia
            Adrian Greeve, Ilya Tregubov, Kevin Percy, Mathew May, Mihail Geshoski, Shamim Rezaie
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: