Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-70793

Missing expired stamp on expired badges

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Deferred
    • Affects Version/s: 3.8.7, 3.9.4, 3.10.1
    • Fix Version/s: None
    • Component/s: Badges
    • Affected Branches:
      MOODLE_310_STABLE, MOODLE_38_STABLE, MOODLE_39_STABLE
    • Difficulty:
      Easy
    • Sprint:
      Moppies Kanban

      Description

      Hi.

      Not sure if it is a bug, but on several installations I noticed that the "Expired" stamp on expired badges is not displayed anymore. Instead there is an exclamation mark above the badge image.

      I could not find any information about this change and the Docs articles still show the stamp. Even the latest badge renderer code still got the stamp icon.

      When deleting the line

      'core:i/expired' => 'fa-exclamation text-warning',

      on

      /lib/classes/output/icon_system_fontawesome.php

      the stamp appears.

      So is this a bug or some kind of feature?

      Greetings.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              sarjona Sara Arjona (@sarjona)
              Reporter:
              mberlin Matthias Berlin
              Participants:
              Component watchers:
              Yuliya Bozhko, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: