Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-7087

Examview XML exports fail whenever there are apostrophes within the answers.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.3
    • Fix Version/s: 1.6.4, 1.7.1, 1.8
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
      Suse Linux, PHP 5, MySQL
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      In Examview, I have attached an export file (Examview XML) that fails to import into Moodle when apostrophe's exist in the answer sets. You may use this file for testing.

        Gliffy Diagrams

          Activity

          howardsmiller Howard Miller added a comment -

          Confirmed.... SQL errors are caused as the question text is not properly escaped. This shows up several other notices as well. I will clean it all up asap.

          howardsmiller Howard Miller added a comment -

          The Examview XML file is different to others I have seen. The text seems to be enclosed in <font> tags that I have not seen in other Examview formats. To illustrate, other examview formats have

          <text>Your answer here</text>

          but the test file has

          <text><font number="2"><font size="10">Your answer here</font></font></text>

          ...which is what seems to be breaking this import. I'm no expert on Examview, so I;m unsure why you are seeing this.

          howardsmiller Howard Miller added a comment -

          Attached file now imports correctly.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                17/Jan/07