Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-71158

Installer broken on php 8.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.10.2
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Affected Branches:
      MOODLE_310_STABLE

      Description

      Steps to reproduce:

      1. Try to run web Moodle installer in php 8.0 (e.g. with compose file below)
      2. View installer in browser

      Expected Results

      Web installer displayed

      Actual results:

       Fatal error: Method lang_string::__set_state() must take exactly 1 argument in /var/www/html/lib/moodlelib.php on line 10692
      

      Additional info

      Installer works on php 7.4 docker container

      Example broken install
      e.g.

      version: '3.3'
       
      services:
        moodle:
          image: moodlehq/moodle-php-apache:8.0
          volumes:
            - /path/to/moodle:/var/www/html
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            poltawski Dan Poltawski
            Participants:
            Component watchers:
            Matteo Scaramuccia, Andrew Lyons, Dongsheng Cai, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: