Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1, 1.8
    • Component/s: Accessibility, Themes
    • Labels:
      None
    • Environment:
      Netscape7, OS9
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      The little triangles separating breadcrumb items are missing, so deciphering what is what on the breadcrumb is a headache.

      I thought it might the issue from MDL-6685 but in Safari, OSX, the separators look like graphics.

        Gliffy Diagrams

          Issue Links

            Activity

            Robert Brenstein added a comment -

            I am of course referring to moodle.org site now running under 1.7

            N Hansen added a comment -

            They are supposed to be graphics, and I see them (in 1.7 with Firefox). I believe one of the reasons they were changed to graphics (in 1.6) was because as text they don't work properly with RTL languages.

            Martin Dougiamas added a comment -

            They look ok to me and have been pretty well tested (although not in Netscape on OS9!).

            Currently we have ditched the graphics in favour of text symbols.

            I suspect/hope you may have just not got the new style sheet. Can you try "CTRL-Refresh" in your browser?

            Robert Brenstein added a comment -

            Sorry, no dice. Refreshing does not change anything. I went as far as restarting computer. I wonder what those characters that look as triangles are. In Safari they are orange solid triangles pointing right. I wonder what font is that. I have quite a few extras loaded and can see properly sites in languages like Polish, Russian, Korean, Chinese, but this may require some font with symbols.

            Martin Dougiamas added a comment -

            (throws up hands)

            We need a solution from someone with the technology ...

            Robert Brenstein added a comment -

            The problem is with the following code in the breadcrumb

            <span class="sep">►</span>

            This entity translates into some non-ascii character (at least according to BBEdit). The problem seems to be Netscape-specific, so my guess is it lacks of the support for the extended entity tables. I say that because iCab displays a graphic character here. It is a down-arrow, which looks strange in a breadcrumb but at least there is a visual separation.

            Robert Brenstein added a comment -

            Sorry, wanted to add that it seems to me that this is a special case of MDL-6685 after all. Looks like the new breadcrumbs were not properly tested under Mac OS9 (admittedly a dying out OS but still fairly common on schools).

            Nick Freear added a comment -

            Fixed as MDL-6685 - let me know if you disagree!

            Thanks.

            Robert Brenstein added a comment -

            I have just installed 1.7.1+ and I see no change. Whether I agree or not with the fix is irrelevant. It does not work for Netscape7 under OS9. The separator is still missing.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: