Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-71417

H5P (core) Internet Explorer (11) Support

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 3.9.6
    • Fix Version/s: None
    • Component/s: H5P
    • Labels:
      None
    • Affected Branches:
      MOODLE_39_STABLE

      Description

      The core H5P code utilises v4.x of the CKEditor. This editor relies on JS promise functionality. Whilst promises are supported by modern browsers, internet explorer requires that they be loaded using a vendor library from the following path:

      • h5p/h5plib/v124/joubel/editor/ckeditor/vendor/promise.js

      This path does not exist in the Moodle core. Looking at a version of the CKEditor downloaded directly the vendor sub-directory does exist and includes a single file - i.e. promise.js.

      I understand that this will only affect branches 3.9 and below due to the policy decision to no-longer support internet explorer after 3.9.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            jjs105 Jon Spain
            Participants:
            Component watchers:
            Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: